01/23/2023, 8:17 PM
Hello, I can't go back more than 90 days on slack, also I don't know - maybe there was already an answer. But I will write again. I am using Rancher Desktop on OS Windows - using WSL2. I need to disable the CNI flannel. Many materials say how to do it in Linux and Mac (via override.yaml - K3S_EXEC="--flannel-backend=none --disable-network-policy). But little how to do it in OS Windows. I'm circling the Windows provisioning script (*.start). It doesn't work out. The goal - to practice network policy in other CNI. That is, synthetically :) - How to disable flannel CNI in Rancher Desktop running on Windows in WSL2. Greetings By the way, great thing is with Traefk. There is a checkbox. If you want to practice with another Ingress - there you go - turn off Traefik. You want to work with Traefik - turn it on. Cool idea.


01/23/2023, 8:26 PM
You can try
rdctl set --flannel-enabled=false


01/23/2023, 11:32 PM
That was the point. Nice tool - rdctl Thank you