https://rancher.com/ logo
#k3s
Title
# k3s
q

quiet-memory-19288

12/06/2022, 5:37 PM
Has anyone noticed k3s shutdown times (on containerd) are super fast if you remove the metrics-server? I tried all kinds of combinations and versions of k3s…. All with same results. Any ideas why?
Ubuntu 20
Copy code
sudo curl -sfL <https://get.k3s.io> | INSTALL_K3S_CHANNEL=v1.25 sh -s - --disable=servicelb,traefik,local-storage,metrics-server --write-kubeconfig-mode 644
Super fast shutdown times If you add metric back:
Copy code
sudo curl -sfL <https://get.k3s.io> | INSTALL_K3S_CHANNEL=v1.25 sh -s - --disable=servicelb,traefik,local-storage --write-kubeconfig-mode 644
It takes a full 90 seconds to shutdown or restart your linux server. So the pod is never getting killed.
That is a ubuntu default on shutdown…
it just kill’s hard after sigterm + 90 seconds
I think its the root cause of this, but no one ever calls out metric server? Am I mistaken? https://github.com/k3s-io/k3s/issues/2400
I need to shut down fast (automotive-ish application)…. Is why I am asking.
c

creamy-pencil-82913

12/06/2022, 6:00 PM
Having any pod at all will make systemd wait for the process to exit before cleaning up the mounts. It doesn't matter what pod it is.
There are examples of adding an shutdown trigger to run the killall script to hard stop the pods
q

quiet-memory-19288

12/20/2022, 6:47 PM
ty!!
46 Views