# rancher-desktop


05/29/2022, 10:38 PM
Hello. I'm currently running Rancher-Desktop (Version 1.2.1) on an M1 mac running macOS 12.3.1 with the dockerd container engine. I've been trying to run a containerized test suite for a Go application, which stalls and eventually fails with a
permission denied
error. After poking around, I have noticed that Go binaries built within the container do not have the executable flag. If I shell into the same container image, with the same runtime config args, build and chmod the binary it runs no problem. I can also pre-compile the test binaries on the host and then run the test suites within the container w/o issue. I tried compiling the binaries in the container, and they all are missing the executable flag. They run fine after I chmod them. Additional sanity checks I have made are as follows: • I updated the base image of the builder container to pick up a newer go version. I was initially running go1.18 and upgraded go1.18.2 • I tried different base images based on libc and musl


05/30/2022, 2:46 AM
Can you please file a Github issue for this? Thanks!