This message was deleted.
# rancher-desktop
a
This message was deleted.
f
I don't understand how this can happen; you should have a dialog like this in front of the app:
You could try disabling administrative access instead of doing the factory reset. Bring up the preferences dialog (Either with
⌘,
or click on the gear icon, and then disable the setting. The stop and restart the app.
n
I do get that first dialog. When I click OK, the system prompt never appears.
f
Admin access is only necessary if you need an externally routable (bridged) IP address, or to get the docker socket symlinked into the default location. You can use
docker context use rancher-desktop
instead for most situations
If you get the first dialog, you can also disable admin access right there
n
okay — but I think there would still be that progress bar? which leads me to believe that something is wrong somewhere.
ah, confirmed — if I disable admin access, it moves on to starting the VM. I remain unclear on why it failed to prompt me.
My knowledge of docker contexts, and when I might want/need to change them, is minimal. I am familiar with kubectl contexts and am guessing it’s similar.
f
I don't know. After you clicked "Ok" you should have gotten a system dialog asking for your password:
n
yeah, that’s what I expected — but it never came up.
f
Rancher Desktop will wait until you dismiss this dialog before it continues. But if you disable admin access, it never needs to prompt you, so doesn't have to wait for the dialog
If you are just using k8s then you don't need to worry about the docker context
n
Right. But I clicked OK on the “administrative access required” dialog, and the “rancher desktop password prompt” dialog simply never appeared. Repeated this several times (with the box unchecked). I am able to bypass via the checkbox, but it seems like there is a bug somewhere.
f
And if you don't want to make your cluster ingress accessible to other machines on the local network, then you don't need to worry about bridged IP addresses either
n
I am not using k8s for this. Trying to manage some docker compose stacks and the various images and containers within.
f
Yes, I'm interested to learn more about this, but have a meeting starting right now. Maybe we can talk some more in an hour and a bit?
👍 1
n
I came to Rancher because we’re being forced off Docker Desktop due to licensing restrictions, and that’s what I’ve used before today. A coworker suggested that Rancher Desktop, along with colima and the docker CLI, was a suitable replacement.
f
What os version and architecture are you on? Are you a local admin? Do you have any corporate management profile installed that may be blocking the dialog?
n
Ventura 13.3.1 on M1. Yes, I’m a local admin. There is a corporate profile, but I have seen such dialogs on this machine before and would not expect that to be the problem.
f
Can you look in the log directory (
~/Library/Logs/rancher-desktop
) and see if there are any references to
sudo
in any of the logs?
Especially take a look at
lima.log
.
n
Copy code
2023-05-01T17:25:06.147Z: Sudoers file /private/etc/sudoers.d/zzzzz-rancher-desktop-lima does not exist, creating.
2023-05-01T17:25:06.149Z: Sudoers file /private/etc/sudoers.d/zzzzz-rancher-desktop-lima needs to be updated.
2023-05-01T17:25:52.609Z: Administrator access disallowed, not using vde/socket_vmnet.
maybe that?
f
No, this is probably after starting without admin access. The log files are wiped on each restart.
n
okay. should I reset?
f
So you would have to re-enable admin access and verify that you don't get the dialog, and then look at the log files
n
that timestamp coincides with when I tried starting without admin
f
Yes, please start with a reset and then capture the logs
n
seeing that first warning, I’m starting lima right now — but I know I already did this earlier today. not sure why it wouldn’t be running. 🤔
f
Not sure what you mean by this. Rancher Desktop has an embedded Lima installation and VM that it manages itself. You should not start/stop it yourself.
There is no more content showing up in the log file?
n
that is the entire file
after a fresh reset, then clicking OK on the “administrative access required” dialog, then waiting ~20 seconds
f
Hmm, let me try it...
n
Not sure what you mean by this. Rancher Desktop has an embedded Lima installation and VM that it manages itself. You should not start/stop it yourself.
Ah, okay. I am also running lima/colima separately. But maybe I shouldn’t do that?
f
It shouldn't matter; the Rancher Desktop setup should be isolated from everything else
And I get the same file content here, but I do get the dialog...
🤔 1
And same setup: macOS 13.3.1 on M1
n
okay, I guess it’s probably my MDM profile. I’ll try a machine reboot later just in case, and otherwise I’ll proceed without admin. Thanks for looking into it for me!
f
Please keep me updated; I would like to understand under which conditions the code can fail to display the dialog
n
will do!
f
This is just the
sudo.exec
call from sudo-prompt - npm, and I can't find any other reports of this behaviour
606 Views