This message was deleted.
# rke2
a
This message was deleted.
s
Copy code
Mar 30 16:21:08 k8s-master-01 rke2[60704]: time="2023-03-30T16:21:08Z" level=debug msg="Tunnel server handing HTTP/1.1 CONNECT request for //192.168.0.14:10250 from 127.0.0.1:33868"
Mar 30 16:21:08 k8s-master-01 rke2[60704]: time="2023-03-30T16:21:08Z" level=debug msg="Tunnel server egress proxy dial error: failed to find Session for client k8s-master-02"
c
the clients aren’t reconnecting to your server. Check the rke2-agent logs to see why.
s
after setting --egress-selector-mode=disabled situation looks that problem is disappeared
c
Yeah that's the wrong fix though. You should figure out why the agents aren't reconnecting to the server. What do you get from
kubectl get node -o wide
?
s
They are in ready state
May be I did not get the question?
254 Views