# general


03/01/2023, 7:09 AM
I am having problems with longhorn 1.2.2: I tried setting up a backup target on a custom S3 endpoint. But we're getting an error:
error listing backup volume names: Timeout executing: /var/lib/longhorn/engine-binaries/rancher-mirrored-longhornio-longhorn-engine-v1.2.2/longhorn [backup ls --volume-only <s3://backups@us-east-1/>], output , stderr, , error <nil>
I tried logging in to the container and checking the probelm from its side and this is what we get:
Copy code
root@longhorn-manager-57lhs:/# /var/lib/longhorn/engine-binaries/rancher-mirrored-longhornio-longhorn-engine-v1.2.2/longhorn backup ls --volume-only <s3://backup/>
ERRO[0020] Fail to list s3: NoCredentialProviders: no valid providers in chain. Deprecated.
	For verbose messaging see aws.Config.CredentialsChainVerboseErrors  pkg=s3
I am sure the credentials in secret are valid and properly formatted ( I've copied minio configuration and adjusted to our environment ). Can anyone from here help us diagnose the problem further and solve it?