https://rancher.com/ logo
#rancher-desktop
Title
# rancher-desktop
a

adamant-kite-43734

02/27/2023, 8:56 PM
This message was deleted.
r

rough-farmer-49135

02/27/2023, 9:37 PM
When a Kubernetes tool looks for http://localhost:8080 then that almost always means it's not seeing the kubeconfig file (default *NIX location of ~/.kube/config ).
👆 1
q

quiet-ghost-96926

02/28/2023, 7:13 PM
@rough-farmer-49135, I hear you. I saw a couple of suggestions on how to fix that, but for some reason--at least on macOS Ventura-- that didn't seem to do it. I wonder if there is something specific to macOS that would cause that?
r

rough-farmer-49135

02/28/2023, 7:16 PM
I'm not a Mac user and only used early Rancher Desktop, so no more info from me. Though you might be able to do better searches with "missing kubeconfig" in your search terms?
👍 1
w

white-xylophone-9961

02/28/2023, 9:52 PM
kubectl config current-context
should show
rancher-desktop
. If not, then check rancher settings and confirm kubernetes cluster started.
☝️ 1
1
q

quiet-ghost-96926

03/01/2023, 7:02 PM
Thank you, @white-xylophone-9961! Apparently I had to delete the config file and start fresh.
w

white-xylophone-9961

03/01/2023, 7:58 PM
I also should've said, try
kubectl config use-context rancher-desktop
to switch to it. You may have other clusters to manage.
🙌 1
🙏 1
Check out k9s too: https://k9scli.io/
🙏 1
q

quiet-ghost-96926

03/02/2023, 7:48 PM
That did it! Thank you 🙂
236 Views