https://rancher.com/ logo
Title
l

lemon-application-97336

02/23/2023, 4:36 PM
sorry, here's my complete question: Hi, I'm trying to install racher 2.7 on an existing Kubernetes Cluster (1.24.10) with external loadbalancer and ssl-termination. I run the installation by helm:
helm upgrade --install rancher rancher-stable/rancher --namespace cattle-system --set hostname="myhost.mydomain" --set tls=external
Installation was ok, but the Ingress reports: 'nginx-ingress-controller Scheduled for sync' In the rancher log I see the following errors:
[ERROR] Failed to connect to peer <wss://10.45.3.4/v3/connect> [local ID=10.45.4.5]: dial tcp 10.45.3.4:443: i/o timeout
I'm confused, I would have expected the internal connections were going to port 80, which is open. Anybody can give me a hint, what could be wrong? Thanks
d

dry-vr-36164

03/11/2023, 12:11 AM
@lemon-application-97336 where you able to solve this issue? If yes please share the solution
l

lemon-application-97336

03/13/2023, 8:15 AM
Hi, I couldn't actually get it working with tls=external, behind an F5-Loadbalancer ­čś× So I switched to back to default. But I still appreciate any hint on how to setup rancher with tls=external. Thanks
d

dry-vr-36164

03/13/2023, 9:00 AM
ok, I had made it work this weekend. Issue for me was tls termination was happening at both places i.e. nginx controller and Rancher. So I disabled tls in rancher with
tls=external
but still it didn't worked. Then I got to know that I had set this as well in nginx controller
--set-string controller.config.use-forwarded-headers="true"
. After adding this it started working.