https://rancher.com/ logo
Title
l

little-ambulance-5584

02/16/2023, 2:42 AM
Anyone notice any troubles using azure-file provisioners on the newer version? One of our old local clusters used to have azurefile persistent volumes and I'm having the hardest trouble doing that on a v1.24.9 cluster.
Warning  FailedAttachVolume  115s (x9 over 20m)  attachdetach-controller  AttachVolume.Attach failed for volume "azurefile-csi" : timed out waiting for external-attacher of <http://file.csi.azure.com|file.csi.azure.com> CSI driver to attach volume unique-volumeid3
  Warning  FailedMount         112s (x4 over 17m)  kubelet                  Unable to attach or mount volumes: unmounted volumes=[data], unattached volumes=[kube-api-access-pbntk data config]: timed out waiting for the condition
I've tried the azure-file, azurefile-csi drivers, I continue to get a plain "timed out waiting for the condition" error with no following logs on any of the containers. It's irritating because the configuration on 1.16 was straight forward and simple. I've tried different storageaccounts and everything. Any ideas?
All PV/PVCs show bound, and I see no errors on the kube logs or docker container logs on the worker node.
the azure storage account shows no errors in logs other than "ClientOther" error with no further details.
a

adventurous-portugal-91104

02/20/2023, 7:48 AM
Im not entirely awake just yet but have you tried to utilized Azure's storage classes ? https://learn.microsoft.com/en-us/azure/aks/concepts-storage#storage-classes