This message was deleted.
# rancher-desktop
This message was deleted.
We only run containerd in a VM, so there wouldn't be anything sensible to export. Not that we do have a trivy-based image scanning feature built in, though; in the UI, going to the Images tab there's a Scan… action within the ⋮ glyph on the right.
That scan option is giving me the same error, cannot find the sock
I tried that before reaching out here
@proud-jewelry-46860 screenshot for context
getting same log and errors when running trivy from terminal as well
Hmm, did we not tell trivy to use `/run/k3s/containerd/containerd.sock`… hmm, works for me (as a data point). (Again, note that you can't see it directly; you'd need to
rdctl shell
to get into the VM to access that socket if you're using the
container engine.)
Ill try setting that path in env and also try rdctl shell
ok, finally was able to test this:
exported at env like:
Copy code
export CONTAINERD_ADDRESS=/run/k3s/containerd/containerd.sock
but still same error
tried rdctl and in the shell and same error