This message was deleted.
# k3s
a
This message was deleted.
c
I would probably take this to #rancher-desktop
d
Hi @creamy-pencil-82913. Thank you for the quick response. Actually, I started with a thread on the rancher-desktop channel. @magnificent-napkin-96586 suggested that I post this question to the #k3s channel, since it appeared to a possible issue with they way that I was configuring k3s Here is a link to the thread on the #rancher-desktop channel. https://rancher-users.slack.com/archives/C0200L1N1MM/p1674771678215759
c
It doesn’t appear to me to be an issue with k3s, but rather how rancher-desktop sets up the VM paths.
the file you’re creating isn’t available in the VM in the location where it needs to be
have you tried just creating the sa.key file at the default location of
/var/lib/rancher/k3s/server/tls/
instead of in
/etc/rancher/k3s/pki/
?
d
Actually, I have tried dropping the RSA files into several different directories for k3s to pick the
sa.key
file. I tried placing the RSA key files the following directories and updating the
config.yaml
to point to the directory: •
/etc/kubernetes/pki
/etc/rancher/k3s/pki
/etc/rancher/k3s
/var/lib/rancher/k3s/server/tls
/var/lib/rancher/k3s/server/pki
/var/lib/rancher/k3s/server
When I log into the
rancher-desktop
distro, I can see that the files are located in the specified folder in the configuration with a mode of 644. However, k3s logs the error stating that the file does not exist. Based on the conversation on the Rancher Desktop thread and the Rancher Desktop documentation, the provisioning scripts execute prior to the start of k3s. I was able to visually verify this is the case. Also, I just retried using the
/var/lib/rancher/k3s/server/tls
directory. Here is the log entry from the k3s.log:
Error: failed to parse service-account-issuer-key-file: open "/var/lib/rancher/k3s/server/tls/sa.key": no such file or directory
c
The error is pretty cut and dried from the k3s side. It’s not there. Are you sure that you’re in the correct VM?
I was under the impression that there are multiple layers of nesting on some platforms
but again I don’t know much about Rancher Desktop
d
It is my understanding that Rancher Desktop installs and runs k3s in their rancher-desktop WSL distro on Windows. I have also verified that the RSA key files are created in the rancher-desktop distro. I will go back to my original thread in the #rancher-desktop and verify this.
277 Views