01/13/2023, 5:22 PM
Hi all, I am installing rancher in a lab where all internet access is intercepted by a proxy which then provides an internally signed certificate. I am installing this on a vsphere environment. I have installed the certificates on the VM template being used and have installed rancher using the helm options --set additionalTrustedCAs=true, followed by the creation of the secret containing the additional cas (as per YET I noticed that when I create new clusters on rancher, the new certificates are not inherited and used by the new clusters. In fact adding a new repo on rancher to the newly created cluster gives "Git clone --depth=1 -n .... SSL certificate problem: unable to get local issuer certificate ...". How can one add custom certificates to the new rancher clusters ?
can anyone help please ?
I get loads and loafs of these time="2023-01-19T12:26:07Z" level=error msg="Unknown error: Get \"\": x509: certificate signed by unknown authority" when logging the cattle-cluster-agent. A colleague tried injecting the certs in the cloud config and still no luck