Hi, today we tried to move the local cluster from ...
# general
Hi, today we tried to move the local cluster from
by following the instructions here: https://fleet.rancher.io/troubleshooting#migrate-the-local-cluster-to-the-fleet-default-cluster After we initialized the move, I could see this in the logs:
Copy code
rancher-5677f59677-shbs7 rancher 2022/12/07 12:39:42 [ERROR] error syncing 'local': handler provisioning-cluster-create: failed to create fleet-default/local <http://provisioning.cattle.io/v1|provisioning.cattle.io/v1>, Kind=
Cluster for provisioning-cluster-create local: admission webhook "<http://rancherauth.cattle.io|rancherauth.cattle.io>" denied the request: cluster name must be 63 characters or fewer, cannot be "local" nor of the form "c
-xxxxx", requeuing
While this was happening, the local clulster had been removed from the
workspace but for the reason above it did not show up in
. We managed to get the cluster back to
again after editing the object, but it would have been nice to have all the "Continuous delivery" clusters in the same workspace. If you have any hints how to make that migration successful, please share 🙂