https://rancher.com/ logo
#rancher-desktop
Title
# rancher-desktop
b

bitter-hairdresser-7812

12/02/2022, 7:48 PM
Rancher Desktop 1.6.2 is filling an awesome role in local dev for our dev teams - thank you! As we're exploring using different ingress controllers so that local dev can match hosted, we're running into an issue where we can't port forward well-known ports (namely 80 & 443) after disabling Traefik even when we grant admin. I can change the port to a higher one like 8443, but when I try port 443 I get this
listen EACCESS: permission denied
error log pasted below. I've factory reset RD and have been extra careful to disable traefik (and do another Reset Kubernetes) but no luck. Changing to higher ports doesn't help us because we want to mimic the hosted envs which use subdomain hostnames (we're also using mkcert) as a local CA.
Copy code
$ tail -f /Users/jyee/Library/Logs/rancher-desktop/k8s.log
2022-12-02T19:35:16.260Z: Setting up new port forwarding to ingress-nginx/ingress-nginx-controller:https...
2022-12-02T19:35:16.261Z: Error: listen EACCES: permission denied 127.0.0.1:443
15 Views