https://rancher.com/ logo
#rancher-desktop
Title
# rancher-desktop
a

adamant-kite-43734

06/17/2022, 10:08 AM
This message was deleted.
c

careful-piano-35019

06/17/2022, 10:29 AM
try
sudo zypper update rancher-desktop
s

sticky-summer-13450

06/17/2022, 10:33 AM
Copy code
> sudo zypper update rancher-desktop
Loading repository data...
Reading installed packages...
No update candidate for 'rancher-desktop-1.3.0-lp153.2.3.x86_64'. The highest available version is already installed.
Resolving package dependencies...
Nothing to do.
👀 1
c

careful-piano-35019

06/17/2022, 10:37 AM
you can certainly force it with
sudo zypper in <https://download.opensuse.org/repositories/isv:/Rancher:/stable/rpm/x86_64/rancher-desktop-1.4.1-lp153.2.2.x86_64.rpm>
not sure about the 'update' strategy regarding rancher-desktop (it might be better to give you the control over when to update rather than getting automatically updated when doing a full
zypper up
(hmmm, I just tried and in my case the update to 1.4.1 was offered by zypper)
oh maybe you need a
zypper refresh
first
s

sticky-summer-13450

06/17/2022, 10:44 AM
Sorry - I should have said that I'd done a
zypper refresh
and a
zypper update
just before, and that pulled in >2000 RPMs.
Oh well - maybe it's just me.
I did
sudo zypper in <the_long_url>
and it's installed for me now.
Thanks for the URL 🙂
👍 1
w

witty-jelly-95845

06/17/2022, 10:48 AM
Do you have the Rancher repo added and enabled?
c

careful-piano-35019

06/17/2022, 10:49 AM
sudo zypper lr --details
s

sticky-summer-13450

06/17/2022, 10:50 AM
I thought about that - so I tried to add it:
Copy code
> sudo zypper addrepo <https://download.opensuse.org/repositories/isv:/Rancher:/stable/rpm/isv:Rancher:stable.repo>
[sudo] password for root: 
Adding repository 'Rancher stable packages (rpm)' ................................................................................................................[error]
Repository named 'isv_Rancher_stable' already exists. Please use another alias.
w

witty-jelly-95845

06/17/2022, 10:51 AM
From my Leap desktop
> zypper lr 10
Alias          : isv_Rancher_stable
Name           : Rancher stable packages (rpm)
URI            : <https://download.opensuse.org/repositories/isv:/Rancher:/stable/rpm/>
Enabled        : Yes
GPG Check      : (r ) Yes
Priority       : 99 (default priority)
Autorefresh    : Off
Keep Packages  : Off
Type           : rpm-md
GPG Key URI    : <https://download.opensuse.org/repositories/isv:/Rancher:/stable/rpm/repodata/repomd.xml.key>
Path Prefix    :
Parent Service :
Keywords       : ---
Repo Info Path : /etc/zypp/repos.d/isv_Rancher_stable.repo
MD Cache Path  : /var/cache/zypp/raw/isv_Rancher_stable
s

sticky-summer-13450

06/17/2022, 10:51 AM
that was just before I did the
sudo zypper install rancher-desktop
which said
The highest available version is already installed
Copy code
> sudo zypper lr --details
#  | Alias                            | Name                          | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                           | Service
---+----------------------------------+-------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------------+--------
...
5 | isv_Rancher_stable               | Rancher stable packages (rpm) | Yes     | (r ) Yes  | No      |   99     | rpm-md | <https://download.opensuse.org/repositories/isv:/Rancher:/stable/rpm/>    
...
w

witty-jelly-95845

06/17/2022, 10:54 AM
Looks the same. My desktop picked up 1.4.1-lp153.2.1 and now I see it's offering 1.4.1-lp153.2.2. Maybe it's a Tumbleweed thing - @bored-farmer-36655 has your desktop got latest RD?
c

careful-piano-35019

06/17/2022, 10:55 AM
I just tried on Tumbleweed
b

bored-farmer-36655

06/17/2022, 12:44 PM
@witty-jelly-95845 Doesn't seem to be on many mirrors https://download.opensuse.org/repositories/isv:/Rancher:/stable/rpm/x86_64/rancher-desktop-1.4.1-lp153.2.2.x86_64.rpm.mirrorlist It does, but I just install direct. @careful-piano-35019 on Tumbleweed your using only zypper up?
👍 1
c

careful-piano-35019

06/17/2022, 1:59 PM
Yes, with zypper up
b

bored-farmer-36655

06/17/2022, 2:24 PM
@careful-piano-35019 for Tumbleweed,
zypper dup
only I normally use
zypper -vvv dup
to add verbosity. Hopefully snapshot 20220614 is the last big one for the year.... now with new gcc hardening option -D_FORTIFY_SOURCE=3 enabled.
s

sticky-summer-13450

06/17/2022, 2:31 PM
If it makes any difference, I'm in the UK/GB. From the mirrors list page @bored-farmer-36655 mentioned the
Mirrors which handle this country:
is an empty list.
Sorry - I'm not too familiar with
zypper
and the install process - most of my resent experience is with Ubuntu - but I've forced myself to use Tumbleweed on this desktop to see whether I think I can jump across.
w

witty-jelly-95845

06/17/2022, 2:39 PM
I'm also in the UK, using openSUSE Leap 15.3 and I see and now updating to latest RD 1.4.1 via "sudo zypper up rancher-desktop"
b

bored-farmer-36655

06/17/2022, 2:50 PM
@sticky-summer-13450 I'm in the US and use it and works fine for me. For my Leap systems I have a mixture just to see the difference.
c

careful-piano-35019

06/17/2022, 2:59 PM
it might be a mirroring delay
b

bored-farmer-36655

06/17/2022, 3:05 PM
@careful-piano-35019 Very very likely, plus there have been a few issues lately with the mirroring setup....
57 Views