This message was deleted.
# k3d
This message was deleted.
Hey there πŸ‘‹ You mean connect to the API via kubectl or to port 80? What error do you see?
port 80 (or 443) as shown by the last
works fine
Copy code
$ kubectl cluster-info
Kubernetes control plane is running at <>
CoreDNS is running at <>
Metrics-server is running at <>

To further debug and diagnose cluster problems, use 'kubectl cluster-info dump'.
Ah.. didn't realize that that was an expandable snippet πŸ€¦β€β™‚οΈ
❀️ 1
All good
Does it work if you bind to a non-privileged port? (I actually never tried k3d with RD, so just asking some questions.. I could give it a try tomorrow)
πŸ‘€ 1
Rather confused why
docker ps
shows the port bindings yet
$ lsof -i :80 | grep LISTEN
shows nothing on that port
Not sure how it works, but could it be that port-forwarding from RD to your localhost doesn't work? (I didn't do research and have no clue how RD does networking)
I might need to learn more about port fowarding w/ RD on Ubuntu. I just didn't have to do anything on the Macbook to get it to work
non-privileged port seems to be fine. just can't wrap my head around why 80/443 would work on macOS and without sudo πŸ˜‚
Additional context for anyone that comes along, I was using this guide which suggests privileged ports are ok. I'm assuming it works on macOS because I granted RD sudo privileges. I also did the same for my Ubuntu machine.
Maybe someone in #rancher-desktop can answer that part πŸ€”
Appreciate the help. Don't think it's a DR issue just yet since I'm creating the cluster with k3d. RD is just, afaik, managing the moby/docker runtime for me. I'm also disabling traefik via
--k3s-arg "--disable=traefik@server:0"
(see above snippet). Keeping traefik enabled results in the same situation, though
Thanks for that link, it's helpful
πŸ‘ 1