06/14/2022, 1:55 PM
Hi, I have two interfaces, ens2 external and ens5 internal vpc, I wanted my cluster to use the internal network, and to achieve that I had to add flags, but I'm not sure if I'm missing something or if I'm making changes that are not required:
Server : not sure if it's needed to change the service-cidr  & cluster-dns
ExecStart=/usr/local/bin/k3s server --data-dir /var/lib/rancher/k3s 
            --flannel-iface "ens5" 
            --kube-scheduler-arg  address=${server_ip} 
            --kubelet-arg address=${server_ip} 
            --bind-address ${server_ip} 
            --service-cidr --cluster-dns 
            --advertise-address ${server_ip} --tls-san value ${server_ip}
nodes : only defined the interface i wanted it to use
ExecStart=/usr/local/bin/k3s agent --server https://{{ k3s_server_address }}:6443 --token {{token}} --flannel-iface "ens5"


06/14/2022, 2:11 PM
That looks perfect. Is it not working?


06/14/2022, 2:17 PM
It's working now, but not correctly at the beggining and I was using the ansible playbook to setup and reset the cluster and , maybe the interfaces were not cleaned correctly so I wanted to make sure I was not missing, anything, and I didn't understand from the doc, what flag to use on the node and what flag to use only on the server.
@bland-account-99790 Thank you Manuel
­čĹŹ 1