# rke


07/19/2022, 1:33 PM
Hello everyone. Today I have upgraded a RKE cluster from 1.21 to 1.22 with RKE v1.3.12 and after the upgrade, the Nginx Ingress controller became unreachable. Here is what I have gathered so far: • Accessing the controller works from within the pod • Accessing the exposed 80 and 443 ports from the node results in a timeout (not connection refused) • The hostPorts used by the controller doesn’t show using
netstat -nltp
• Found some suggestions on GitHub to use host network for the controller instead of host ports. Tried it, doesn’t change anything. However ports 80 and 443 shows on netstat. • I have applied a workaround by manually creating a NodePort service for the controller and re-configuring our load balancer trough to use the service. Anyone has any ideas why this might happen or any additional steps to debug?
More info: • The timeout happens before even being able to write the request, not while awaiting a response. • The 8443 webhook port works properly from the node, so the issue is specific to 80 and 443 ports
Update: I still have no idea what the issue was but rebooting the nodes solved the issue