https://rancher.com/ logo
Title
e

eager-church-7365

11/24/2022, 1:02 PM
Hi everyone, I ran into this issue when trying to install rancher-desktop from source on windows. Does anyone have an idea on how to solve this?
npm ERR! code 1
npm ERR! path C:\Users\Imane\Downloads\rancher-desktop\node_modules\ffi-napi
npm ERR! command failed
npm ERR! command C:\WINDOWS\system32\cmd.exe /d /s /c node-gyp-build
npm ERR! gyp info it worked if it ends with ok
npm ERR! gyp info using node-gyp@9.1.0
npm ERR! gyp info using node@16.18.1 | win32 | x64
npm ERR! gyp info find Python using Python version 3.10.8 found at "C:\Users\Imane\scoop\apps\python\current\python.exe"
npm ERR! gyp info find VS using VS2017 (15.9.33027.88) found at:
npm ERR! gyp info find VS "C:\Program Files (x86)\Microsoft Visual Studio\2017\BuildTools"
npm ERR! gyp info find VS run with --verbose for detailed information
npm ERR! gyp info spawn C:\Users\Imane\scoop\apps\python\current\python.exe
npm ERR! gyp info spawn args [
npm ERR! gyp info spawn args   'C:\\Users\\Imane\\scoop\\persist\\nvm\\nodejs\\v16.18.1\\node_modules\\npm\\node_modules\\node-gyp\\gyp\\gyp_main.py',
npm ERR! gyp info spawn args   'binding.gyp',
npm ERR! gyp info spawn args   '-f',
npm ERR! gyp info spawn args   'msvs',
npm ERR! gyp info spawn args   '-I',
npm ERR! gyp info spawn args   'C:\\Users\\Imane\\Downloads\\rancher-desktop\\node_modules\\ffi-napi\\build\\config.gypi',
npm ERR! gyp info spawn args   '-I',
npm ERR! gyp info spawn args   'C:\\Users\\Imane\\scoop\\persist\\nvm\\nodejs\\v16.18.1\\node_modules\\npm\\node_modules\\node-gyp\\addon.gypi',
npm ERR! gyp info spawn args   '-I',
npm ERR! gyp info spawn args   'C:\\Users\\Imane\\AppData\\Local\\node-gyp\\Cache\\16.18.1\\common.gypi',
npm ERR! gyp info spawn args   '-Dlibrary=shared_library',
npm ERR! gyp info spawn args   '-Dvisibility=default',
npm ERR! gyp info spawn args   '-Dnode_root_dir=C:\\Users\\Imane\\AppData\\Local\\node-gyp\\Cache\\16.18.1',
npm ERR! gyp info spawn args   '-Dnode_gyp_dir=C:\\Users\\Imane\\scoop\\persist\\nvm\\nodejs\\v16.18.1\\node_modules\\npm\\node_modules\\node-gyp',
npm ERR! gyp info spawn args   '-Dnode_lib_file=C:\\\\Users\\\\Imane\\\\AppData\\\\Local\\\\node-gyp\\\\Cache\\\\16.18.1\\\\<(target_arch)\\\\node.lib',
npm ERR! gyp info spawn args   '-Dmodule_root_dir=C:\\Users\\Imane\\Downloads\\rancher-desktop\\node_modules\\ffi-napi',
npm ERR! gyp info spawn args   '-Dnode_engine=v8',
npm ERR! gyp info spawn args   '--depth=.',
npm ERR! gyp info spawn args   '--no-parallel',
npm ERR! gyp info spawn args   '--generator-output',
npm ERR! gyp info spawn args   'C:\\Users\\Imane\\Downloads\\rancher-desktop\\node_modules\\ffi-napi\\build',
npm ERR! gyp info spawn args   '-Goutput_dir=.'
npm ERR! gyp info spawn args ]
npm ERR! gyp: C:\Users\Imane\AppData\Local\node-gyp\Cache\16.18.1\common.gypi not found (cwd: C:\Users\Imane\Downloads\rancher-desktop\node_modules\ffi-napi) while reading includes of binding.gyp while trying to load binding.gyp
npm ERR! gyp ERR! configure error
npm ERR! gyp ERR! stack Error: `gyp` failed with exit code: 1
npm ERR! gyp ERR! stack     at ChildProcess.onCpExit (C:\Users\Imane\scoop\persist\nvm\nodejs\v16.18.1\node_modules\npm\node_modules\node-gyp\lib\configure.js:284:16)
npm ERR! gyp ERR! stack     at ChildProcess.emit (node:events:513:28)
npm ERR! gyp ERR! stack     at Process.ChildProcess._handle.onexit (node:internal/child_process:293:12)
npm ERR! gyp ERR! System Windows_NT 10.0.22621
npm ERR! gyp ERR! command "C:\\Users\\Imane\\scoop\\apps\\nvm\\current\\nodejs\\nodejs\\node.exe" "C:\\Users\\Imane\\scoop\\persist\\nvm\\nodejs\\v16.18.1\\node_modules\\npm\\node_modules\\node-gyp\\bin\\node-gyp.js" "rebuild"
npm ERR! gyp ERR! cwd C:\Users\Imane\Downloads\rancher-desktop\node_modules\ffi-napi
npm ERR! gyp ERR! node -v v16.18.1
npm ERR! gyp ERR! node-gyp -v v9.1.0
npm ERR! gyp ERR! not ok
j

jolly-forest-99711

11/24/2022, 11:37 PM
This looks similar to an error I helped some other people through. They were on Linux, though. I ended up adding some documentation to the linux development instructions: https://github.com/rancher-sandbox/rancher-desktop#linux. The relevant bullet point starts with about "Dependencies described in the node-gyp...". If you install the dependencies listed there, does this solve your problem?
e

eager-church-7365

12/08/2022, 1:34 PM
Thank you for your help. I already have those dependencies installed and it still does not solve the issue