https://rancher.com/ logo
Title
b

brief-eve-68728

11/09/2022, 2:52 PM
Hi, Anyone got any idea what might be wrong with my Windows pc? This all happened after I updated to the latest version of Rancher Desktop which previously worked fine. Rancher gets stuck at startup at this step: 'Updating /etc/hosts Error: could not detect WSL2 VM: could not find WSL2 VM ID: could not dial VM 8D0784A5-6234-4457-B567-D775E173BDB5: could not dial Hyper-V socket: connect(8d0784a5-6234-4457-b567-d775e173bdb5:016a6eb7-facb-11e6-bd58-64006a7986d3) failed: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. Error: vsockListen, could not determine VM GUID: could not find vsock-peer process on any hyper-v VM(s) time="2022-11-09T14:30:31+02:00" level=info msg=Listening endpoint="unix:///var/run/docker.sock" 2022-11-09T13:12:23.265Z: Auth failure: user/password validation failure for attempted login of user interactive-user Thanks!
f

freezing-tailor-4245

11/09/2022, 6:30 PM
Looks like a problem with the WSL2 VM. Would try, if you have not done that already, to factory reset Rancher Desktop.
p

proud-jewelry-46860

11/09/2022, 9:10 PM
In this particular case,
wsl --shutdown
(while Rancher Desktop is not running) might help too, since WSL creates a new VM every time. (Generally the error is from the GUI being unable to talk to the VM, which means something may be wrong with its
rancher-desktop-guest-agent
service inside WSL.)
b

brief-eve-68728

11/10/2022, 7:59 AM
@freezing-tailor-4245 Did that twice.. still doesn't want to work.
@proud-jewelry-46860 this morning seems to be working after letting it sit for a few days 😅`
thanks everyone..
no idea why it works now..
1