https://rancher.com/ logo
#general
Title
# general
a

adamant-kite-43734

11/09/2022, 8:36 AM
This message was deleted.
a

agreeable-oil-87482

11/09/2022, 9:28 AM
For a downstream cluster? Did you enable authorised cluster endpoint?
1
b

big-air-84716

11/14/2022, 8:23 AM
Thank you for the hint! I found out that by default
Copy code
local_cluster_auth_endpoint
is set to
false
and this has been the reason. By the way using Rancher UI i don`t found a option to select it. I directly edit YAML of cluster using Rancher Edit option.
a

agreeable-oil-87482

11/14/2022, 8:47 AM
In the UI it's a selectable option. In slightly different places depending if it's rke1 or rke2
1
b

big-air-84716

11/14/2022, 11:55 AM
Thank you. I double check now and I found it under
Cluster Management->Networking
! Strange is that menu is visible only if i select new version of K8s itself. If i just open Edit screen
Network
menu is missing,
Add-On config
is empty...
a

agreeable-oil-87482

11/14/2022, 12:00 PM
Which version of Rancher and what cluster type is that?
b

big-air-84716

11/14/2022, 12:00 PM
Rancher v2.6.8 RKE2
a

agreeable-oil-87482

11/14/2022, 12:00 PM
Which node driver?
b

big-air-84716

11/14/2022, 12:00 PM
Custom installation on premise, Calico
After update from 1.24.4 to 1.24.7 UI issue disappear and not i see all the time
Networking
sub menu when I am on Edit cluster page