https://rancher.com/ logo
#rancher-desktop
Title
# rancher-desktop
a

adamant-kite-43734

10/31/2022, 5:37 PM
This message was deleted.
j

jolly-forest-99711

10/31/2022, 5:48 PM
Can you provide the steps you took to get to this? I'll give it a shot on my machine
a

adorable-leather-68471

10/31/2022, 6:07 PM
Copy code
kubectl apply -f <https://github.com/kubernetes-sigs/metrics-server/releases/latest/download/components.yaml>
j

jolly-forest-99711

10/31/2022, 10:40 PM
It seems to be working fine for me:
Copy code
C:\Users\adamk\dev\test\k8s> kubectl -n kube-system logs -f metrics-server-7f97cd9c75-hmt9w
I1031 22:39:07.195125       1 serving.go:342] Generated self-signed cert (/tmp/apiserver.crt, /tmp/apiserver.key)
I1031 22:39:07.451088       1 requestheader_controller.go:169] Starting RequestHeaderAuthRequestController
I1031 22:39:07.451110       1 tlsconfig.go:240] "Starting DynamicServingCertificateController"
I1031 22:39:07.451114       1 configmap_cafile_content.go:201] "Starting controller" name="client-ca::kube-system::extension-apiserver-authentication::client-ca-file"
I1031 22:39:07.451141       1 shared_informer.go:240] Waiting for caches to sync for client-ca::kube-system::extension-apiserver-authentication::client-ca-file
I1031 22:39:07.451114       1 shared_informer.go:240] Waiting for caches to sync for RequestHeaderAuthRequestController
I1031 22:39:07.451164       1 dynamic_serving_content.go:131] "Starting controller" name="serving-cert::/tmp/apiserver.crt::/tmp/apiserver.key"
I1031 22:39:07.451168       1 configmap_cafile_content.go:201] "Starting controller" name="client-ca::kube-system::extension-apiserver-authentication::requestheader-client-ca-file"
I1031 22:39:07.451208       1 shared_informer.go:240] Waiting for caches to sync for client-ca::kube-system::extension-apiserver-authentication::requestheader-client-ca-file
I1031 22:39:07.451101       1 secure_serving.go:266] Serving securely on [::]:4443
W1031 22:39:07.451388       1 shared_informer.go:372] The sharedIndexInformer has started, run more than once is not allowed
I1031 22:39:07.552230       1 shared_informer.go:247] Caches are synced for RequestHeaderAuthRequestController
I1031 22:39:07.552271       1 shared_informer.go:247] Caches are synced for client-ca::kube-system::extension-apiserver-authentication::client-ca-file
I1031 22:39:07.552243       1 shared_informer.go:247] Caches are synced for client-ca::kube-system::extension-apiserver-authentication::requestheader-client-ca-file
a

adorable-leather-68471

10/31/2022, 10:41 PM
Hmm… bummer! I wonder what it could be. I’ll try deleting the node in hope the new one will come up fine.
j

jolly-forest-99711

10/31/2022, 10:41 PM
I haven't dug into what it's used for and tried it for that, but I wonder if it is an issue with your environment. Are you running on an M1 mac running Ventura by any chance? There is a known issue with some versions of k8s
a

adorable-leather-68471

10/31/2022, 10:43 PM
yeah m1
j

jolly-forest-99711

10/31/2022, 10:46 PM
Are you running ventura? And k8s version 1.24.* or 1.25.*? https://github.com/rancher-sandbox/rancher-desktop/issues/3288 might help
a

adorable-leather-68471

10/31/2022, 10:46 PM
I’m on Monterey, k8s version 1.21
j

jolly-forest-99711

10/31/2022, 11:15 PM
Hmm well the issue I posted wouldn't be the one then. I'm not sure what the issue would be. Is there anything of interest in the RD logs?
a

adorable-leather-68471

11/01/2022, 1:06 AM
Ok, after deleting the node and restarting RD it works now. Something about the old node that was a little funky then 🤷
👍 1
s

steep-airplane-89460

11/24/2022, 1:07 PM
What I have noticed / is that the image builder will build to the "default image namespace" by default (no pun intended) - And I have found no quick way via cli command to change that - because to have them run in a k8s/k3s/node, they have to built to the k8s.io image namespace - so your choices are 1) to rebuild it to the k8s.io namespace (which takes longer or 2) save the image to a .tar file and load it back because the load command DOES have the option for a namespace (this worked for me) / fyi
849 Views