This message was deleted.
# rancher-desktop
This message was deleted.
@calm-sugar-3169 can you take a look?
did icmp work before? most companies don’t route icmp to the internet so it may be a better test to ping a dns server or other core appliance on the otherside of your VPN connection
nslookup should work against the DNS configured in your vpn which commonly will be private
@microscopic-crayon-31537 the ICMP should work from within the
distro with the workaround mentioned. However, something to keep in mind is if you restart any of the following; your machine, VPN client or Rancher Desktop you will have to run the
again, since it is not persistent (I believe there is a persistent flag on those commands but you should avoid them, it may result into unknown problems). Are you able to trigger the
to see if it works again? BTW, this is not a permanent solutions from Rancher Desktop, this is just a workaround for us to understand the core of the issue with WSL routing when VPN tunnel is enabled.
@calm-sugar-3169 ty! it seems i needed to execute those commands more often.. Get-NetIPInterface was lying to me showing 5001 and 1, but apparently that wasn't the truth..