This message was deleted.
# harvester
a
This message was deleted.
t
When you ran through the installer. Did you see all your network devices? Did you select on that is up? Sounds like it can’t see a network card. Can you verify the port is active on the switch side?
n
Yes there were two nics on the system, both visible. One up and one down. The latter which was not networked so this was no surprise. The installer won't let you use a downed networked interface anyway (I tried) so I could only choose the only up NIC. Currently that NIC and provided IP address are pingable and reachable on the network - so I don't see any issues there. The management address is the issue, but it seems like the rancherd service won't complete starting up properly anyway.
t
Can you ssh into the node externally? You can double check the settings in
/oem/harvester.config
n
ssh works fine. The IP address I put this on doesn't seem to have any problem. It's the management Virtual IP that isn't starting up because rancherd is having issues
How does one ssh into it by default though? root and the password made during setup doesn't work (probably just as well for security). Do I have to make my own users?
a
good news is that the
ssh
still works for the first node, try to get below information:
Copy code
sudo -i  
kubectl get pods -A
kubectl get service -A
kubectl get managedchart -A
kubectl get bundle -A
kubectl get bundledeployment -A
ps aux
ip link
ip addr
cat /oem/harvester.config
t
the install should “just work”. I suspect there is something wrong with the vlanning in the configs that isn’t allowing the kubelet to start.
a
kubelet does not care vlan
we need to know how is the
node ip
and
vip
are set, static or `dhcp`; and if the IPs are stable
if `ip`s are not stable, then it has trouble, k8s does not allow node to change ip
t
thus check the config….
n
I think it's something network related. I have another server on the network and harvester install won't even let me configure the network. The error message is vague "Configure network failed: fork/exec /usr/bin/yip: input/output error"
All the IPs I am setting are statically set. No DHCP anywhere
ok, so the /usr/bin/yip error happened because my virtually mounted CD image fell off my iLO. I am trying a reinstall now and we will see how it goes
OK, reinstalled. Same issue with kubectl -n fleet-local wait --for=condition=Provisioned=true clusters.provisioning.cattle.io
OK, it worked this time. I guess the problem was the Dell iDRAC kicking off my mounted iso mid-install and then rebooting before I could see an error on screen. Problem solved!
👍 1
perhaps if the install fails in future, present the user with a message that the install has failed on bootup and if they really want to continue. That's the only thing I can suggest to work around this.
I walked away after setting it up to install and came back to find harvester up at it's console screen, but little did I know that it failed install and was running a corrupted instance.
t
Huzzah