This message was deleted.
# rancher-desktop
a
This message was deleted.
f
idk; which platform. i'll be in meetings for at least the next 2 hours, so can't really look
b
macOS Big Sur. Reset k8s already. Understood about meetings.
Update: now, the LoadBalancers now getting addresses in the VM’s eth0 network range
Not a new thing, appears closed, why I’m experiencing it? https://github.com/rancher-sandbox/rancher-desktop/issues/901
f
It depends on if you allow admin access or not. If you do, you get a bridged interface on the local network. If you don't, then you only have user-mode networking over slirp to localhost
This should not be different from 1.5.1 though. All I can think off is that you have disabled admin access (sudo)
b
I’ve noticed that RD stopped asking me for admin access - which explains the issue - how can I restore it?
f
It is in the Preferences dialog: ⌘, and then select "Administrative Access"
b
I never changed it 😕
I’ll flip it twice and see if RD starts asking
f
What do you get when you run
rdctl shell ip a show rd0
?
b
Copy code
[oleg:~/projects/helm_bgvault_noprod] main* 1 ± rdctl shell ip a show rd0
ip: can't find device 'rd0'
Error: exit status 1
this is with the box unchecked
f
Yes, that is expected; you need
root
to be able to start the vmnet daemon for the bridged interface
b
but when k8s restarts and I check the box again, RD doesn’t ask for a sudo password
f
Ok, please check again for the
rd0
interface
b
OK, now I got this:
Copy code
[oleg:~/projects/helm_bgvault_noprod] main* 1 ± rdctl shell ip a show rd0
4: rd0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:55:55:ba:b3:30 brd ff:ff:ff:ff:ff:ff
    inet 172.21.120.218/16 scope global rd0
       valid_lft forever preferred_lft forever
    inet6 fe80::5055:55ff:feba:b330/64 scope link
       valid_lft forever preferred_lft forever
f
But the loadbalancer doesn't get an IP address from that network range?
b
let me see
nope, it gets IP of eth0
Copy code
[oleg:~/projects/helm_bgvault_noprod] main* ± rdctl shell ip a show eth0
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 52:55:55:ba:a7:be brd ff:ff:ff:ff:ff:ff
    inet 192.168.5.15/24 scope global eth0
       valid_lft forever preferred_lft forever
    inet6 fec0::5055:55ff:feba:a7be/64 scope site dynamic flags 100
       valid_lft 86250sec preferred_lft 14250sec
    inet6 fe80::5055:55ff:feba:a7be/64 scope link
       valid_lft forever preferred_lft forever
f
I think I can repro 😞 That would be a regression from 1.5.1
b
so I need to somehow get to RD asking me for a sudo access
yeah, looks like a regression. How can I downgrade to 1.5.1?
f
No, the
sudo
part is fine (RD writes
/etc/sudoers.d/zzzzz-rancher-desktop-lima
the first time, so unless your host interfaces change, it can restart the daemons without asking you for the password again)
There is no way to downgrade without destroying the VM. You can do a Factory Reset and then install 1.5.1 on top.
b
as a wild suggestion, if you used zfs in lima vm, you’d be able to take snapshots and rollback during the install/rollback process 🙂
f
Yeah 🙂 There is a lot we can do when we have more time 🙂
b
it can restart the daemons without asking you for the password again
sure, but when I shut down RD and start it again, it should ask, no?
There is a lot we can do when we have more time
I’m thankful to you guys that you have any time at all
back to downgrading - is removing $USER/Library/Application Support/rancher-desktop sufficient to destroy the VM?
I’d love to test 1.6 more but now it’s a blocker; I have to work on my app so downgrade is fine by me
f
Yeah, probably, but doing a Factory Reset does the same thing, so I would use that. Just check the option to keep the cached images, so you don't need to download again
b
Ah, OK so I just install 1.5.1, start it and do Factory Reset? I think I did that but it asked me to upgrade to 1.6 .first 😞
f
It is good you noticed the issue; we already have 2 other bugs that warrant a patch release, so this will be included as well I think
b
Nice, glad to be of help!
f
Oh, sorry, you have to disable automatic updates before you quit 1.5.1, otherwise it will automatically upgrade you to 1.6.0 on restart
b
right - will do that first thing
alright, I’m back to business, thank you for your help, @fast-garage-66093!
f
It is just missing the initial
--
in front of
flannel-iface
😞
Some bug introduced during refactoring
b
I’ll be keeping an eye on updates/patches. For now I had to modify my instructions to not use 1.6.0, as sad as it is
bug introduced during refactoring
Yeah, automated refactoring tools are known for this - I just dealt with OPNsense bug which also dealt with interfaces, introduced by refactoring and was in the codebase for 6+ month
can’t really test everything, esp. when short on resources
If it’s not too pressing to ask, do you have an ETA for the patch in mind? This is a nasty bug; I spent a couple of hours easy chasing it
f
I would hope before the end of the week. I'm somewhat disturbed that we found 3 patch-worthy issues so short after the release, so I hope we won't find any more.
b
Thanks! Important is that you’ve found them, not how many. There’s always more 🙂 but not as bad
101 Views