This message was deleted.
# longhorn-storage
This message was deleted.
Here’s an example of this happening
Is there an issue?
Or am I overlooking something?
Or is a specific version of helm required?
We are continue working to support k8s v1.25 and higher (reference #4003). So it is recommended to upgrade to v1.3.2 when your k8s version is >= v1.18 and <= v1.24.
My Kubernetes version is v1.24.4+k3s1
So shouldn’t it work on that version no issues - on v1.3.1 or v1.3.2 of Longhorn @narrow-egg-98197
I’m actually trying to upgrade to v1.3.0 and above
So this happens when I try to specify exactly the v1.3.2 version of Longhorn. So not on v1.3.1 .. is something iffy on v1.3.2?
Would you mind to input
kubectl version
and share the result?
Tracked it down further … seems to be the
helm template …
command itself … we run
Copy code
ytt ... | helm template longhorn/longhorn --namespace longhorn-system --version 1.3.2 --values -
we get the err. But when we use:
Copy code
ytt ... | helm upgrade --install --atomic longhorn/longhorn -version 1.3.2 --create-namespace --namespace longhorn-system --values -
No issue
👀 1
Output from
kubectl version
Copy code
[linuxlars@LT-PF1ADC4J iac-conductor (⎈ |default:default)]$ kubectl version
WARNING: This version information is deprecated and will be replaced with the output from kubectl version --short.  Use --output=yaml|json to get the full version.
Client Version: <http://version.Info|version.Info>{Major:"1", Minor:"25", GitVersion:"v1.25.2", GitCommit:"5835544ca568b757a8ecae5c153f317e5736700e", GitTreeState:"clean", BuildDate:"2022-09-21T14:25:45Z", GoVersion:"go1.19.1", Compiler:"gc", Platform:"linux/amd64"}
Kustomize Version: v4.5.7
Server Version: <http://version.Info|version.Info>{Major:"1", Minor:"24", GitVersion:"v1.24.4+k3s1", GitCommit:"c3f830e9b9ed8a4d9d0e2aa663b4591b923a296e", GitTreeState:"clean", BuildDate:"2022-08-25T03:45:26Z", GoVersion:"go1.18.1", Compiler:"gc", Platform:"linux/amd64"}
So client-side my kubectl is v1.25.2 … could that be the issue?
Upgraded to v3.10.1 of Helm and still the same issue
I try it on my laptops, and I can also reproduce it.
After I searched the Helm documentation, I thought that when Helm renders templates, it is based on the latest k8s version.
I think you can add
--kube-version <your_k8s_version>
when try to rendering the templates like this
helm template longhorn/longhorn --namespace longhorn-system --version 1.3.2 --kube-version 1.24.4
👍 2
It works in my environment. Would you mind trying it out in your environment?
I’ll sure try this. Nice find. I think you’re right. Thank you. I’ll try this tomorrow!
🙂 1
I’ve now tried it and yes that works. We’ll simply implement pinning the version of the cluster onto which the Longhorn version is going to be installed to match the actual live cluster version. Thank you very much for the support. Much appreciated!
🙌 1