This message was deleted.
# rke2
a
This message was deleted.
c
Have you looked at the Cilium tab of the RKE2 CNI docs? https://docs.rke2.io/install/network_options/
a
thanks. that explains how to disable kube-proxy on rke2 installation.
but how can i pass the
--disable-kube-proxy
in Rancher Manager 2.6.8 ?
c
Oh, just set
kubeProxyReplacement: "strict"
in the Cilium Configuration when provisioning the cluster
It’s the very first thing in the Add-On Config section.
and for adding the --disable-kube-proxy flag… that’s a good question.
You might have to edit as YAML and add it to the machineGlobalConfig? That’s really a Rancher question, not RKE2.
a
thank you. I’ll try that!
457 Views