09/27/2022, 5:19 PM
I've installed rancher desktop (Moby, not nerdctl) on a windows 11 machine. however, still have docker desktop AND podman desktop installed. I can't seem to run docker in a WSL box (notably, my WSL distro is called Ubuntu-22.04, not "Ubuntu"). Rancher > Preferences > WSL shows
Ubuntu-22.04: Error: File /c/users/<user>/.kube/config exists and is not a symlink
and is grayed out. • Additionally, I can't run docker in the wsl prompt.
$ docker ps
  Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?
• is there something i need to 'clear' or 'reset' first? Am I supposed to uninstall docker desktop / podman desktop?


09/28/2022, 2:09 PM
Hi Michael, as the error message states, in you have already an existing
file. The path is the one on Windows, so I guess you might have created a symlink on your Ubuntu distro that points to your Windows home (either the full home, or just
directory). That being said, in your Ubuntu distro, if you rename the
directory, you'll see that the box won't be grayed anymore in Rancher Desktop. Finally, due to this error, the docker socket is indeed not installed in your Ubuntu distro and that's why you can't run docker commands successfully


09/29/2022, 3:18 AM
Thanks - I stopped rancher desktop, deleted
and restarted rancher desktop. It recreated a fresh
but preferences>WSL still gave me the same error. I've tried changing rancher to the containerd instead of moby, but
also gives me an error inside WSL. This has to do with no systemd, i believe.
FATA[0001] rootless containerd not running? (hint: use ` install` to start rootless containerd): stat /wslg/runtime-dir/containerd-rootless: no such file or directory