https://rancher.com/ logo
Title
c

creamy-mechanic-63134

09/19/2022, 12:26 PM
Hi Team Getting this error while doing longhorn upgrade
\"<http://backingimagemanagers.longhorn.io|backingimagemanagers.longhorn.io>\" is invalid: status.storedVersions[1]: Invalid value: \"v1beta2\": must appear in spec.versions && cannot patch \"<http://backingimagedatasources.longhorn.io|backingimagedatasources.longhorn.io>\" with kind CustomResourceDefinition: <http://CustomResourceDefinition.apiextensions.k8s.io|CustomResourceDefinition.apiextensions.k8s.io> \"<http://backingimagedatasources.longhorn.io|backingimagedatasources.longhorn.io>\" is invalid: status.storedVersions[1]: Invalid value: \"v1beta2\": must appear in spec.versions && cannot patch \"<http://backuptargets.longhorn.io|backuptargets.longhorn.io>\" with kind CustomResourceDefinition: <http://CustomResourceDefinition.apiextensions.k8s.io|CustomResourceDefinition.apiextensions.k8s.io> \"<http://backuptargets.longhorn.io|backuptargets.longhorn.io>\" is invalid: status.storedVersions[1]: Invalid value: \"v1beta2\": must appear in spec.versions && cannot patch \"<http://backupvolumes.longhorn.io|backupvolumes.longhorn.io>\" with kind CustomResourceDefinition: <http://CustomResourceDefinition.apiextensions.k8s.io|CustomResourceDefinition.apiextensions.k8s.io> \"<http://backupvolumes.longhorn.io|backupvolumes.longhorn.io>\" is invalid: status.storedVersions[1]: Invalid value: \"v1beta2\": must appear in spec.versions && cannot patch \"<http://backups.longhorn.io|backups.longhorn.io>\" with kind CustomResourceDefinition: <http://CustomResourceDefinition.apiextensions.k8s.io|CustomResourceDefinition.apiextensions.k8s.io>
upgrading from 1.2.2 to 1.3.1
q

quick-sandwich-76600

09/21/2022, 2:40 PM
May you double check the process follwed the upgrade guide? https://longhorn.io/docs/1.3.1/deploy/upgrade/longhorn-manager/ Which exact upgrade method did you used: from Rancher catalog, Helm or Kubectl?
c

creamy-mechanic-63134

09/21/2022, 4:35 PM
i have followed the documentation, and have used helm to upgrade the longhorn
q

quick-sandwich-76600

09/21/2022, 9:54 PM
Ok, and what method did you use for the initial deployment. Helm also? The catalog?
Can you also run this command and share the output: helm list --namespace longhorn-system
And, please paste also the exact helm command you used for the upgrade.
c

creamy-mechanic-63134

09/22/2022, 3:16 AM
yes, we followed the helm approach to deploy the longhorn 1.2.2 version as well
q

quick-sandwich-76600

09/22/2022, 7:01 AM
I've seen the same error on one of our support forums and it suggest that actually an accidental downgrade was produced. The reference to v1beta2 seems to suggest that. That's why it's important to see the output of this command: helm list --namespace longhorn-system
c

creamy-mechanic-63134

09/22/2022, 7:02 AM
i am trying to create the env. will share the output once env is ready
­čĹŹ 1