This message was deleted.
# rancher-desktop
This message was deleted.
It feels to me it has a security issue. WLS is the process in windows replacement for control plane pods afaik
Hmm, you might be able to pull the command it's running from
(in the Troubleshooting section in the main window there's a button to show the logs in Explorer) and try running it manually. (I have no idea what security issue comment is about… WSL is just helping to run a Linux VM.)
Do you have antivirus on the machine?
I'm experiencing this same issue. And, for whatever reason, RD also downloads a new Linux kernel despite already having WSL installed This is the output at install time of Rancher Desktop
And on launch of RD
Log shows
Copy code
2022-08-16T08:12:37.240Z: Registered distributions: podman-machine-default
2022-08-16T08:12:41.949Z: Registered distributions: podman-machine-default
2022-08-16T08:12:42.280Z: Registered distributions: podman-machine-default
2022-08-16T08:12:42.439Z: WSL failed to execute wsl.exe --import rancher-desktop C:\Users\Tao Hansen\AppData\Local\rancher-desktop\distro C:\Users\Tao Hansen\AppData\Local\Programs\Rancher Desktop\resources\resources\win32\distro-0.26.tar --version 2: Error: wsl.exe exited with code 4294967295
The error we are having is the following
2022-08-03T114809.132Z: Registered distributions: 2022-08-03T114809.868Z: Registered distributions: 2022-08-03T114824.040Z: Registered distributions: rancher-desktop 2022-08-03T114824.348Z: Registered distributions: rancher-desktop 2022-08-03T114824.349Z: Creating initial data distribution... 2022-08-03T114934.981Z: Unmounting missing device /dev/sdd: 342 341 8:48 / /mnt/wsl/rancher-desktop/run/data rw,relatime shared:8 - ext4 /dev/sdd rw,discard,errors=remount-ro,data=ordered 2022-08-03T114936.657Z: Did not find a valid mount, mounting /mnt/wsl/rancher-desktop/run/data 2022-08-03T114948.751Z: WSL: executing: cat /root/.docker/config.json: Error: wsl.exe exited with code 1 2022-08-03T115003.134Z: Installing C:\Users\2098\AppData\Local\Programs\Rancher Desktop\resources\resources\linux\internal\trivy as /mnt/c/Users/2098/AppData/Local/Programs/Rancher Desktop/resources/resources/linux/internal/trivy into /usr/local/bin/trivy ...
c in case it helps i did write a guide for rancher here but not sure if your issue is slightly different
Hi everyone, I have solved the issue. Firstly, I set the default version of WSL to 2. It is like this --> wsl --set-default-version 2 Then, I removed Rancher. After restarting the computer, I installed Rancher with a different version of Kubernetes than I tried before. It suddenly worked!