08/11/2022, 10:51 AM
Hi all, I’m having issues changing the virtual Machine resources for Rancher Desktop, I’m just wondering if anyone else has had this issue and knows of some kind of workaround. Info It’s two brand new MacBook Pro M1’s with a fresh install of Rancher Desktop, I used brew to install it, kubernetes disabled, using moby. I have it installed on a couple other identical Mac’s which where done a couple months ago and they all work fine.


08/11/2022, 8:30 PM
That seems odd. Could you post
~/Library/Application Support/rancher-desktop/lima/0/lima.yaml
(probably as a snippet)? That is the underlying file in use to set up the VM, and should have a


08/11/2022, 9:36 PM
Thanks, that’s good to know, I’ll have a look tomorrow, while waiting for a reply I lowered the memory to 2gb which worked correctly, I then set it to 4gb unfortuantly it was once again set at 3gb, as a work around I removed 1.5.0 and put 1.4.1 on which worked perfectly. I haven’t tried to updating any of the Mac’s to 1.5.0 since this happened I’m guessing it will be fine as we have a couple more on 1.5.0 that work fine. It seems to be just fresh installs on 1.5.0
I have upgraded from 1.4.1 to 1.5.1 and it has changed the memory back to 3gb, looking at the file you mentioned above, I can see it is setup correctly. I’ll have to downgrade it again, I’m really not sure what this is.
Fixed, updating the mac to whatever the latest OS is appears to fix it, thanks for all your help.