https://rancher.com/ logo
Title
f

faint-airport-39912

08/11/2022, 7:25 AM
I am trying to add new master node in the highly available k3s setup (I am using postgres as database to store the state of k3s) and here is the command curl -sfL https://get.k3s.io | sh -s - server --datastore-endpoint='postgres://k3s:ypassword@192.168.11.5:5432/k3s' I m using to add new master node but it is giving me following error so can you someone look into it and help ??
hello everyone, can you please look into above error message and suggest what can be done in order to fix the error ??
t

tall-school-18125

08/12/2022, 7:36 AM
The same token should be used for each node joined to the cluster. You may need to append
--token YOUR_TOKEN
to the command
f

faint-airport-39912

08/12/2022, 5:55 PM
@tall-school-18125 Thanks for the reply, I also tried with token option but same error . Is there anything i am missing here ?
curl -sfL https://get.k3s.io | sh -s - server --datastore-endpoint='postgres://k3s:ycypasswordYo@192.168.1013:5432/k3s' --token='K102xxxxx''
@tall-school-18125 Do you any other suggestion on this problem ?
t

tall-school-18125

08/17/2022, 6:07 PM
Can you also validate that your k3s nodes fulfill the port requirements? https://rancher.com/docs/k3s/latest/en/installation/installation-requirements/#networking
f

faint-airport-39912

08/19/2022, 12:12 PM
@tall-school-18125 I have checked and all required ports are open. Not sure what else i can do here to fix it. ­čś× ?
t

tall-school-18125

08/19/2022, 5:27 PM
You could try asking in #k3s
f

faint-airport-39912

08/20/2022, 7:28 AM
ok Thanks