This message was deleted.
# k3s
a
This message was deleted.
g
Do you have a manifest configured in
/var/lib/rancher/k3s/server/manifests
as well that specifies to use cilium, and have the flags in config to not use the built in cni? If not, you’ll need those as well to make sure k3s knows to use cilium (and its images you’ve loaded there) instead of flannel
c
I do have the flag for the network (indeed when k3s starts it starts without the network pods) but I miss the manifests files. So this could be the reason. Thanks a lot for your help Max!
👍 1
one last question: I'm having problems using the manifest to deploy cilium because it find that the node is not ready (and oc it's not ready because the network is missing 😄 :
Copy code
0/1 nodes are available: 1 node(s) had untolerated taint {<http://node.kubernetes.io/not-ready|node.kubernetes.io/not-ready>: }. preemption: 0/1 nodes are available: 1 Preemption is not helpful for scheduling.
is there a way to avoid this? I'm thinking about the manual removal of the not-ready taint, but I guess it's not really safe to do
the other option could be add a toleration in the helmchart values, but again I'm not sure to do the correct thing
110 Views