https://rancher.com/ logo
Title
b

breezy-autumn-81048

05/11/2023, 12:51 PM
Hi community, I was trying to import the existing K3S cluster v1.26 to Rancher. Thus, have chose "Import existing cluster", but couldn't find a command that would import the K3S: Rancher version: 2.7.3 Deployment: Helm Installed on the K3S cluster version: v1.24 Is it a bug? Thanks in advance,
h

hundreds-evening-84071

05/11/2023, 2:14 PM
it does not look like 1.26 is supported yet: https://www.suse.com/suse-rancher/support-matrix/all-supported-versions/rancher-v2-7-3/ But, which command is not found? It cannot find
kubectl
? Or something else?
b

breezy-autumn-81048

05/11/2023, 2:19 PM
Hi @hundreds-evening-84071 , As you can see it says "Run kubectl command below on an existing Kubernetes cluster running a supported Kubernetes version to import it into Rancher:", but in fact, the command is missing, there is just an empty code block below.
h

hundreds-evening-84071

05/11/2023, 2:30 PM
Oh, you are correct; sorry... totally missed that in your screen shot
b

brainy-printer-12087

05/12/2023, 9:45 AM
I have a different view ­čĄö
b

breezy-autumn-81048

05/12/2023, 10:23 AM
Hi @brainy-printer-12087 , Which Rancher version do you use?
b

brainy-printer-12087

05/12/2023, 11:24 AM
latest
h

hundreds-evening-84071

05/12/2023, 1:11 PM
I think that is the screen we get when we create from Rancher UI... But for importing existing cluster its different screen? In import screen we do not have check boxes for etcd, control plane and worker
I have Rancher v2.7.3 (stable channel)
b

brainy-printer-12087

05/12/2023, 3:16 PM
yeah I used creation and then command ops