https://rancher.com/ logo
#random
Title
# random
a

adamant-kite-43734

05/02/2023, 6:36 PM
This message was deleted.
1
c

creamy-pencil-82913

05/02/2023, 6:40 PM
You need to deploy and configure the aws cloud provider, provide it with credentials, and tag your resources appropriately.
Also, out of the box rke2-ingress-nginx is configured to use nodeport not LoadBalancer service
so you’d want to change that as well if you want it to use a service
l

little-art-55288

05/02/2023, 6:41 PM
can you please provide a link with these steps? I am deploying my own nginx controller, not using out of the box rke2-ingress-nginx
c

careful-appointment-9763

05/02/2023, 6:42 PM
I'm using this Controller and end up with empty target groups https://kubernetes-sigs.github.io/aws-load-balancer-controller/
@creamy-pencil-82913 any suggestions? #amazon
l

little-art-55288

05/02/2023, 6:44 PM
i am using this chart which works well if rke2 cluster is deployed via rancher. version: "4.0.19" repository: https://kubernetes.github.io/ingress-nginx
c

creamy-pencil-82913

05/02/2023, 6:46 PM
rke2 already comes with ingress-nginx, did you deploy it twice?
or are you referring to the one that comes with rke2
l

little-art-55288

05/02/2023, 6:47 PM
i am deploying my own; not using out of the box nginx controller that is in kube-system namespace
c

creamy-pencil-82913

05/02/2023, 6:55 PM
you should either use or disable the built-in one; we don’t test or support it with multiple instances of the nginx controller deployed to the same cluster.
❤️ 1
l

little-art-55288

05/02/2023, 6:58 PM
ok
trying it with the following steps: disable out of the box ingress controller. enable cloud-provider=aws iam role is attached to the instances, so no extra configuration should be required.
Thank you @creamy-pencil-82913. I am still trying but you gave me a good direction. Highly appreciated.
it worked ... yayyy 🙂
7 Views