This message was deleted.
# general
This message was deleted.
Is it possible to enable an external identity provider such as Azure AD using API? Activating this feature is not working when using the Helm Chart and setting an extraEnv environment variable for Rancher deployment.
Im Trying This
Copy code
curl -u "token-xxxx:pw8txxxxxxxxxxxxxxxxxxxxxxxxxxg2x66fh" \
-H 'Accept: application/json' \
-H 'Content-Type: application/json' \

HTTP/1.1 POST /v3/users
Host: 1x.1xx.1xx.1xx
Accept: application/json
Content-Type: application/json
Content-Length: 307

"annotations": {
"<|>": "true"
"description": "Test For Rancher Automation",
"enabled": true,
"labels": {
"<|>": "norman"
"mustChangePassword": true,
"name": "Rancher Test",
"password": "password123@3545%098g",
"principalIds": [ ],
"username": "ranchertester"
But Its Not Working. Getting This As An Error:
Copy code
curl: (60) SSL certificate problem: self-signed certificate in certificate chain
More details here: <>

curl failed to verify the legitimacy of the server and therefore could not
establish a secure connection to it. To learn more about this situation and
how to fix it, please visit the web page mentioned above.
Are you using the self-signed certificate ? Please make sure to add
to the curl command
Using ALB. and Also Added -k And Tried. Still Same Issue
Here's another option that may be useful to you: you can create the user directly from the Rancher UI, and then inspect the web page to see the rights information that the user is using to make this request possible
It seems to be a issue with your SSL certificate
But make sure before if you are not missing a importent filed in your request payload
Ok. Will Give It A Try