Hi, I'm trying to get a fresh Rancher install runn...
# general
m
Hi, I'm trying to get a fresh Rancher install running on a local cluster, following this Rancher Academy course. Having successfully installed the Rancher Helm chart, I got to the login webpage and tried using my bootstrap password to log in, but without success (
401
), although this command returned precisely the password I was using in my login attempts:
Copy code
kubectl get secret --namespace cattle-system bootstrap-secret -o go-template='{{.data.bootstrapPassword|base64decode}}{{"\n"}}'
The login page also claims that
if you pre-set your own bootstrap password, enter it here. Otherwise a random one has been generated for you.
so I tried reinstalling the chart without specifying a password, to see if that would make any difference. Yet now:
Copy code
$ kubectl get secret --namespace cattle-system bootstrap-secret -o go-template='{{.data.bootstrapPassword|base64decode}}{{ "\n" }}'
Error from server (NotFound): secrets "bootstrap-secret" not found
It looks like no random password generation actually happened. Any ideas about what I'm doing wrong? Happy to create a Github issue if you feel it's relevant. Thanks!
130 Views