https://rancher.com/ logo
Title
b

brash-belgium-72831

04/04/2023, 10:31 PM
To install Rancher 2.7.1 (Latest) do i need to "INSTALL_K3S_VERSION=v1.24.6+k3s1"? Can't i use the lastest k3s?
c

creamy-pencil-82913

04/04/2023, 10:32 PM
no, you need to use a version of Kubernetes that Rancher supports.
you can check the Rancher support matrix to find out what that is
đź‘Ť 1
b

brash-belgium-72831

04/04/2023, 10:38 PM
Thank you! OHH! So that's why I never got Rancher to work. Is that a big deal to use v1.24.6+k3s1 instead of v1.26.3+k3s1 or is it always like that, "common practice" with Kubernetes? I thought latest was always the best path. I did understand that is the requirement for Rancher specifically.
c

creamy-pencil-82913

04/04/2023, 10:40 PM
the patch level isn’t as important as the minor version
Rancher only supports up to 1.24 at the moment
b

brash-belgium-72831

04/04/2023, 10:41 PM
OH! i thought it was even the minor! Good to know! Thank you!
c

careful-piano-35019

04/06/2023, 8:59 PM
the main reason is the end of PSP in 1.25