03/22/2023, 8:54 AM
Good afternoon. Out of the blue this morning when trying to use rancher desktop my instance is stuck on 'error starting kubernetes' . When checking the logs, i can see this on k8s.txt :
2023-03-22T08:47:29.290Z: Updating release version cache with 130 items in cache
2023-03-22T08:47:30.943Z: Skipping pre-release v1.26.3-rc1+k3s1
2023-03-22T08:47:30.944Z: Skipping pre-release v1.25.8-rc1+k3s1
2023-03-22T08:47:30.944Z: Skipping pre-release v1.24.12-rc1+k3s1
2023-03-22T08:47:30.944Z: Found old version v1.26.2+k3s1, stopping.
2023-03-22T08:47:30.950Z: Got 130 versions.
2023-03-22T08:47:31.655Z: Ensuring images available for K3s 1.25.7
2023-03-22T08:47:34.006Z: Cache at C:\Users\nicola.a\AppData\Local\rancher-desktop\cache\k3s is valid.
2023-03-22T08:48:06.208Z: Waiting for K3s server to be ready on port 6443...
2023-03-22T08:48:06.875Z: Error: Client network socket disconnected before secure TLS connection was established
2023-03-22T08:48:07.659Z: Updating kubeconfig C:\Users\nicola.a\.kube\config...
i'm including also the k3s logs. Anyone that can help me understanding what the issue is ?


03/22/2023, 4:01 PM
Antivirus? VPN? Firewall? If you switch to a k8s 1.24.x, do things work?


03/22/2023, 6:31 PM
tried with 1.24.11, still no luck. I use a windows 10 pro operative system and i don't have any specific antivirus and firewall solution. I didn't to any change to my configuration lately and this worked fine till 2 or 3 days ago. I use a VPN trough a client called ZScaler, but this was not an issue in the past