https://rancher.com/ logo
Title
c

careful-honey-96496

03/20/2023, 7:38 PM
Hi all, I am new to k3s. I am trying to set it up in sysbox. • I setup an ubuntu 22.04 vm in Azure • Installed https://docs.docker.com/engine/install/ubuntu/#install-using-the-repository on the VM • Installed https://github.com/nestybox/sysbox/blob/master/docs/user-guide/install-package.md#installing-sysbox on the VM • On the VM I ran
docker run --runtime=sysbox-runc -it --rm -P --hostname=syscont nestybox/ubuntu-bionic-systemd-docker:latest
• From with in the System container I ran
docker run --name k3s-server-1 --hostname k3s-server-1 -p 6443:6443 -d rancher/k3s:v1.24.10-k3s1 server
I can see the k3s-server container is running, but all pods are on pending and it doesn’t show the server node. In the logs of the k3s container I see this message/ error:
Waiting to retrieve agent configuration; server is not ready: \"overlayfs\" snapshotter cannot be enabled for \"/var/lib/rancher/k3s/agent/containerd\", try using \"fuse-overlayfs\" or \"native\": failed to mount overlay: operation not permitted
Anyone who has experience in setting up k3s in Sysbox? Haven’t been able to find where I can adjust the snapshotter to native for example.
c

creamy-pencil-82913

03/20/2023, 8:26 PM
you’re missing the --privileged flag in your
docker run
command