03/18/2023, 6:36 PM
Interesting longhorn replica eviction behavior I bumped into. So: • disabled scheduling on all disks on a longhorn node • Set eviction to true on the disks on the same node As there’s no other node to actually “take on” the evicted replicas nothing happens. I enable disk scheduling again. However, without setting eviction requested to false on all the disks on the node. The replicas on the node gets doubled. I know I may be fooling around a bit here. But, still - isn’t this unintended behavior? Thank you