https://rancher.com/ logo
Title
s

sparse-artist-18151

03/13/2023, 9:47 PM
how to add the following to the cluster.yaml
kube-proxy-arg:
  - proxy-mode=ipvs
  - ipvs-strict-arp=true
I added the following based on - link but metallb is still not ARPing with the Loadbalancer IP
kubeproxy:
      extra_args:
        ipvs-scheduler: lc
        proxy-mode: ipvs
c

creamy-pencil-82913

03/13/2023, 9:49 PM
RKE2 doesn’t have a cluster.yaml. It has a config.yaml at /etc/rancher/rke2/
s

sparse-artist-18151

03/13/2023, 10:11 PM
@creamy-pencil-82913 thanks for the response, sorry that was my mistake, let me rephrase it im talking about when we create a cluster using RKE and edit the configuration, how do we apply the IPVS config?
https://www.suse.com/support/kb/doc/?id=000020035 based on this KB i added the config in to the YAML file but the Metallb is still not working properly, is there a better or a native way to handle loadbalancing VIPs on Rancher (RKE)?
c

creamy-pencil-82913

03/13/2023, 10:40 PM
Are you asking questions about RKE? This is the RKE2 channel, they function very differently
s

sparse-artist-18151

03/16/2023, 1:47 AM
RKE1 and RKE2 has the same issues, it turned out to be the kernel modules when i checked the kubeproxy logs
0313 21:44:08.315888  108645 feature_gate.go:245] feature gates: &{map[]}
I0313 21:44:08.346872  108645 proxier.go:652] "Failed to load kernel module with modprobe, you can ignore this message when kube-proxy is running inside container without mounting /lib/modules" moduleName="nf_conntrack_ipv4"
E0313 21:44:08.347024  108645 server_others.go:107] "Can't use the IPVS proxier" err="IPVS proxier will not be used because the following required kernel modules are not loaded: [ip_vs_lc]"
Enable the modules by adding the following conf file and reboot the nodes
sudo nano /etc/modules-load.d/ipvs.conf
ip_vs_lc
ip_vs
ip_vs_rr
ip_vs_wrr
ip_vs_sh
nf_conntrack_ipv4